summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-axolotl')
-rw-r--r--dev-python/python-axolotl/python-axolotl-0.2.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-axolotl/python-axolotl-0.2.3-r1.ebuild b/dev-python/python-axolotl/python-axolotl-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..e0f66f75e82c
--- /dev/null
+++ b/dev-python/python-axolotl/python-axolotl-0.2.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for the axolotl protocol"
+HOMEPAGE="https://github.com/tgalal/python-axolotl"
+SRC_URI="https://github.com/tgalal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-axolotl-curve25519[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest