summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-daemon/python-daemon-2.3.2.ebuild')
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-daemon/python-daemon-2.3.2.ebuild b/dev-python/python-daemon/python-daemon-2.3.2.ebuild
new file mode 100644
index 000000000000..b2605240e226
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="
+ https://pagure.io/python-daemon/
+ https://pypi.org/project/python-daemon/
+"
+
+# build system and tests use GPL-3.0+ but none of these files are installed
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ~ppc ppc64 ~sparc x86"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest