summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-debian/python-debian-0.1.40.ebuild')
-rw-r--r--dev-python/python-debian/python-debian-0.1.40.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/python-debian/python-debian-0.1.40.ebuild b/dev-python/python-debian/python-debian-0.1.40.ebuild
deleted file mode 100644
index 093dbb450db3..000000000000
--- a/dev-python/python-debian/python-debian-0.1.40.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2011-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python modules to work with Debian-related data formats"
-HOMEPAGE="https://salsa.debian.org/python-debian-team/python-debian"
-SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-
-RDEPEND="
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? ( app-arch/dpkg )
-"
-
-distutils_enable_tests unittest
-
-PATCHES=( "${FILESDIR}/0.1.39-disable-apt-pkg.patch" )
-
-python_compile_all() {
- ${EPYTHON} lib/debian/doc-debtags > README.debtags || die
-}
-
-python_test() {
- eunittest lib
-}