summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-designateclient')
-rw-r--r--dev-python/python-designateclient/Manifest1
-rw-r--r--dev-python/python-designateclient/python-designateclient-2.3.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-designateclient/Manifest b/dev-python/python-designateclient/Manifest
index fa576d63d7fe..fc796396d25a 100644
--- a/dev-python/python-designateclient/Manifest
+++ b/dev-python/python-designateclient/Manifest
@@ -1 +1,2 @@
DIST python-designateclient-2.0.0.tar.gz 63215 SHA256 516e883b74726eae0b24755dff682857bb6b11b26dc06eb231ffee5a696e48a8 SHA512 e5c10915d6f5619949b385096e2bce02e1115c4842ae315ffbd4488b29703fb0a038628818c80364c32461b4f9eeb083e2877c38a15bd4f6ec323942957c75bc WHIRLPOOL 732e8d4378074fb8c78ab40659fae8eca7a81fe831714cd1d62588d784be66e43d80fceb5344adb679371fec47a309c2e3c984eae976a29b293ef0788d729c2d
+DIST python-designateclient-2.3.0.tar.gz 78445 SHA256 f41e533cd9eda72638ce288e3dfad1e18cfc4210bd9ca248d70939ff2fccf856 SHA512 f45194f3d04c139148bb11f16b7df0d7a701548c37d99bbac52d1f0badc2cb1ff7a7fda801a2556899fe51ae17903903214a558798e04ccb9ec4b6d994fd5d41 WHIRLPOOL 56472534b08b60bd6e48df0023c7b76beefc09fd02d2163c70721c5346c7fd13ba551cda4a2cd9a97ab6356f43d6ed14e8fcc0622b973b81631b1758253c15dc
diff --git a/dev-python/python-designateclient/python-designateclient-2.3.0.ebuild b/dev-python/python-designateclient/python-designateclient-2.3.0.ebuild
new file mode 100644
index 000000000000..9962031baac2
--- /dev/null
+++ b/dev-python/python-designateclient/python-designateclient-2.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the Designate API."
+HOMEPAGE="https://github.com/openstack/python-designateclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/cliff-1.15.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-1.16.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]"