summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-editor')
-rw-r--r--dev-python/python-editor/Manifest1
-rw-r--r--dev-python/python-editor/metadata.xml3
-rw-r--r--dev-python/python-editor/python-editor-1.0.3.ebuild20
3 files changed, 22 insertions, 2 deletions
diff --git a/dev-python/python-editor/Manifest b/dev-python/python-editor/Manifest
index 6605b8a5ba9f..5ef63616a927 100644
--- a/dev-python/python-editor/Manifest
+++ b/dev-python/python-editor/Manifest
@@ -1 +1,2 @@
DIST python-editor-0.4.tar.gz 6516 SHA256 4421a7116bf3af957266f225bc79ad25b92839cc7974c8335bba5a6582edd3bf SHA512 f1fd4660e67e8299a6f9183e85a1e213e1156542d84eae6644e4f42e5e2804f813857ee50bd8833728b320415ee6f2be5df4ca69acb10a709f20d2306eb5e7ad WHIRLPOOL 2c68e5749bf7955315888a3bed45d3f3b68ef575804342e1391269a9f6f05ddce43242dc988dd29e805f9c165e06731b857238bdebd94e2e5c1f2f7181da24d9
+DIST python-editor-1.0.3.tar.gz 6975 SHA256 a3c066acee22a1c94f63938341d4fb374e3fdd69366ed6603d7b24bed1efc565 SHA512 258d1ea17ea1c09d8ef52d3b624cc17710559f4a8db3c64696f72aecfcc0830d3509dcdcc9d1ac272155b2aaab432edb7142b0a37f2c3263a2505bff940a3cab WHIRLPOOL e0bddecfe9c818916b306aab9c4acaf4efa5c1b2e405b221203939d3c01ef5bcc3ed8c2109a45dedbbe447ebeff02c3d17fe23dc8e40698e5206b19dd3ee5337
diff --git a/dev-python/python-editor/metadata.xml b/dev-python/python-editor/metadata.xml
index f8b8f83e002e..3c5614e4b63d 100644
--- a/dev-python/python-editor/metadata.xml
+++ b/dev-python/python-editor/metadata.xml
@@ -5,9 +5,8 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
- <longdescription lang="en">
- </longdescription>
<upstream>
+ <bugs-to>https://github.com/fmoo/python-editor/issues</bugs-to>
<remote-id type="github">fmoo/python-editor</remote-id>
<remote-id type="pypi">python-editor</remote-id>
</upstream>
diff --git a/dev-python/python-editor/python-editor-1.0.3.ebuild b/dev-python/python-editor/python-editor-1.0.3.ebuild
new file mode 100644
index 000000000000..841a33093d34
--- /dev/null
+++ b/dev-python/python-editor/python-editor-1.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Programmatically open an editor, capture the result."
+HOMEPAGE="https://github.com/fmoo/python-editor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"