summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-etcd/python-etcd-0.4.5.ebuild')
-rw-r--r--dev-python/python-etcd/python-etcd-0.4.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-etcd/python-etcd-0.4.5.ebuild b/dev-python/python-etcd/python-etcd-0.4.5.ebuild
new file mode 100644
index 000000000000..75ff1044e92b
--- /dev/null
+++ b/dev-python/python-etcd/python-etcd-0.4.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python client for etcd"
+HOMEPAGE="https://github.com/jplana/python-etcd https://pypi.python.org/pypi/python-etcd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=virtual/python-dnspython-2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.7.1[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-db/etcd
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}