summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-evdev')
-rw-r--r--dev-python/python-evdev/Manifest1
-rw-r--r--dev-python/python-evdev/python-evdev-1.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-evdev/Manifest b/dev-python/python-evdev/Manifest
index a1b03f58df3c..131f10648e05 100644
--- a/dev-python/python-evdev/Manifest
+++ b/dev-python/python-evdev/Manifest
@@ -1 +1,2 @@
DIST python-evdev-1.3.0.tar.gz 85018 BLAKE2B ba5c391631ecf8cc0a46f21830209c59b1217940ff25e051e027bc8896d71965a394f222f4e3d629ba2a2f8056ccbdc0dfaf43a37684d7157c7456d61f2d8314 SHA512 392fb4fabed344e6db4e257d4cfc7043393efda15d940be80b013e4c4e350334148a7b04aa0a7239f824ad2c7e0bb057c5cff1c0f320d30b25b0c9aab65a6891
+DIST python-evdev-1.4.0.tar.gz 86010 BLAKE2B 958d85f852e88a27fd22ec2511ba1367a69141f294d96f55d45fb5da176c539aef09a6c65d31be87581d0176571c7bd1ca84d580e920e460c3ca810d8efa45be SHA512 a98552bb1c5075c73ebb0a2a3a0fb241e061ed476d5342c8e8e23b3da86fa769a7d5d8027cfa243542d8b62efb89a9b1daf1c4768173295cd466714e4c53029d
diff --git a/dev-python/python-evdev/python-evdev-1.4.0.ebuild b/dev-python/python-evdev/python-evdev-1.4.0.ebuild
new file mode 100644
index 000000000000..ba10259d1388
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-1.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="https://python-evdev.readthedocs.io/"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile build_ecodes \
+ --evdev-headers \
+ "${SYSROOT}"/usr/include/linux/input.h:"${SYSROOT}"/usr/include/linux/input-event-codes.h
+}
+
+python_test() {
+ # test_uinput requires write access to /dev/uinput
+ pytest -vv --deselect tests/test_uinput.py ||
+ die "tests failed for ${EPYTHON}"
+}