summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/metadata.xml16
-rw-r--r--dev-python/python-slugify/python-slugify-1.2.6.ebuild23
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
new file mode 100644
index 000000000000..07c93725a49e
--- /dev/null
+++ b/dev-python/python-slugify/Manifest
@@ -0,0 +1 @@
+DIST python-slugify-1.2.6.tar.gz 8439 BLAKE2B 74699bf80408e1b6a705525b0ada2612cc6224a2ac1e17ce21230ed684af144c0f72ad99b32674bf19bd716d2cfc3a2f0da6f74facc99acba16e3ebc1873f3f3 SHA512 ad45958d03892d8db75967b150f25509c05ab2a87d5ac4a2ed12fccccfe1f86d7db26c406c6de22ba759b77fe772cc0c00d0e517c71db085618f62094ddadfd2
diff --git a/dev-python/python-slugify/metadata.xml b/dev-python/python-slugify/metadata.xml
new file mode 100644
index 000000000000..8ba37583de7b
--- /dev/null
+++ b/dev-python/python-slugify/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo.2019@r123.de</email>
+ <name>Robert Siebeck</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-slugify</remote-id>
+ <remote-id type="github">un33k/python-slugify</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-slugify/python-slugify-1.2.6.ebuild b/dev-python/python-slugify/python-slugify-1.2.6.ebuild
new file mode 100644
index 000000000000..eed79aeecdd2
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-1.2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="https://github.com/un33k/python-slugify https://pypi.org/project/python-slugify/"
+SRC_URI="https://github.com/un33k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/unidecode[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest