summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.8.1.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.8.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.8.1.ebuild b/dev-python/python-stdnum/python-stdnum-1.8.1.ebuild
new file mode 100644
index 000000000000..9bd98db12525
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( || ( dev-python/zeep dev-python/suds ) )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests || die
+}