summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild')
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
deleted file mode 100644
index 4aee43ee2b1b..000000000000
--- a/dev-python/python-swiftclient/python-swiftclient-3.7.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings to the OpenStack Object Storage API"
-HOMEPAGE="https://launchpad.net/python-swiftclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" )
-
-python_prepare_all() {
- sed -i '/hacking/d' "${S}/test-requirements.txt" || die "sed failed"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- testr init
- testr run || die "tests failed under python2_7"
- flake8 tests && einfo "run of tests folder by flake8 passed"
- flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed"
-}