summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild')
-rw-r--r--dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild b/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
deleted file mode 100644
index c3c2c1f2eca4..000000000000
--- a/dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A utility belt for advanced users of python-requests"
-HOMEPAGE="https://toolbelt.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
-IUSE="test"
-
-RDEPEND="<dev-python/requests-3.0.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/betamax[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst HISTORY.rst README.rst )
-
-PATCHES=(
- "${FILESDIR}/requests-toolbelt-0.8.0-test-tracebacks.patch"
- "${FILESDIR}/requests-toolbelt-0.9.1-tests.patch"
-
- # disable python2.7 test failures with newer requests versions
- # bug: https://bugs.gentoo.org/635824
- # https://github.com/requests/toolbelt/issues/213
- "${FILESDIR}/requests-toolbelt-0.9.1-tests-py2.patch"
-
- # disable tests that require internet access
- "${FILESDIR}/requests-toolbelt-0.9.1-tests-internet.patch"
-
- "${FILESDIR}/requests-toolbelt-0.9.1-py310.patch"
-)
-
-distutils_enable_tests pytest