summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sarge')
-rw-r--r--dev-python/sarge/Manifest1
-rw-r--r--dev-python/sarge/sarge-0.1.7_p1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sarge/Manifest b/dev-python/sarge/Manifest
index 0c3af5a7d48b..68d5ebce195b 100644
--- a/dev-python/sarge/Manifest
+++ b/dev-python/sarge/Manifest
@@ -1 +1,2 @@
DIST sarge-0.1.7.gh.tar.gz 57029 BLAKE2B 4cba823073b6699d9a3152b55de63b8ea9ba7cafa0f50556d6c2115a863fd3cae44a9d8fc9e6bf14727aa312c90f69dd03ebcb73508c5a2cdb0d1f6ff190435f SHA512 f2017fdab137e1aebfcd60a125ea7ff057158c6bf6a277d3084db73ed62a07cfd3464deba883284980c9f6ea3f56810effb551e8e8523ab750a086895ad0297a
+DIST sarge-0.1.7.post1.gh.tar.gz 57121 BLAKE2B 4e7f9cf21e2492303fb7ae24d8f5da22fc6db4d04449e5e6063825d2c2163333456fed35af53b5107a80996ca4e036c8913c1d50ffd1d0386e4f3d3f0e46dbda SHA512 29e783287d9e2325e6183d3d56fb2247e3ec98e728dbb69c8391694b2456c1d9ce91a4a172d8ba66593d0553d016fca34b5253d7a4d4f02c1f2d6a3a19574097
diff --git a/dev-python/sarge/sarge-0.1.7_p1.ebuild b/dev-python/sarge/sarge-0.1.7_p1.ebuild
new file mode 100644
index 000000000000..017e909afcc9
--- /dev/null
+++ b/dev-python/sarge/sarge-0.1.7_p1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Wrapper for subprocess which provides command pipeline functionality"
+HOMEPAGE="
+ https://docs.red-dove.com/sarge/
+ https://pypi.org/project/sarge/
+ https://github.com/vsajip/sarge/
+"
+SRC_URI="
+ https://github.com/vsajip/sarge/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+python_test() {
+ "${EPYTHON}" test_sarge.py -v || die "Tests failed with ${EPYTHON}"
+}