summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.6.3.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/scipy/scipy-1.6.3.ebuild b/dev-python/scipy/scipy-1.6.3.ebuild
index e98e4bd93794..08a959a4ad0b 100644
--- a/dev-python/scipy/scipy-1.6.3.ebuild
+++ b/dev-python/scipy/scipy-1.6.3.ebuild
@@ -108,6 +108,13 @@ python_prepare_all() {
sed -e "s:== 'levy_stable':in ('levy_stable', 'crystalball', 'ncf'):" \
-i scipy/stats/tests/test_continuous_basic.py || die
+ if has_version ">=sci-libs/lapack-3.10"; then
+ sed -e 's:test_sort(:_&:' \
+ -i scipy/linalg/tests/test_decomp.py || die
+ sed -e 's:test_solve_discrete_are:_&:' \
+ -i scipy/linalg/tests/test_solvers.py || die
+ fi
+
distutils-r1_python_prepare_all
}