summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/semantic-version/semantic-version-2.10.0.ebuild')
-rw-r--r--dev-python/semantic-version/semantic-version-2.10.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/semantic-version/semantic-version-2.10.0.ebuild b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
index 94bca6f84951..6cde6827cc60 100644
--- a/dev-python/semantic-version/semantic-version-2.10.0.ebuild
+++ b/dev-python/semantic-version/semantic-version-2.10.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -23,5 +23,6 @@ distutils_enable_sphinx docs \
distutils_enable_tests pytest
python_test() {
- epytest -p no:django
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
}