summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/singledispatch/singledispatch-3.4.0.3-r1.ebuild')
-rw-r--r--dev-python/singledispatch/singledispatch-3.4.0.3-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/singledispatch/singledispatch-3.4.0.3-r1.ebuild b/dev-python/singledispatch/singledispatch-3.4.0.3-r1.ebuild
new file mode 100644
index 000000000000..c6fdce9e9b7c
--- /dev/null
+++ b/dev-python/singledispatch/singledispatch-3.4.0.3-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to bring functools.singledispatch from Python 3.4 to Python 2.6-3.3"
+HOMEPAGE="http://docs.python.org/3/library/functools.html#functools.singledispatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"