summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/smartypants/smartypants-2.0.1-r1.ebuild')
-rw-r--r--dev-python/smartypants/smartypants-2.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/smartypants/smartypants-2.0.1-r1.ebuild b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..c5c6b78000bf
--- /dev/null
+++ b/dev-python/smartypants/smartypants-2.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{6..10} )
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+inherit distutils-r1
+
+DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
+HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+distutils_enable_sphinx docs
+distutils_enable_tests setup.py