summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/smartypants')
-rw-r--r--dev-python/smartypants/Manifest1
-rw-r--r--dev-python/smartypants/metadata.xml15
-rw-r--r--dev-python/smartypants/smartypants-2.0.1.ebuild32
-rw-r--r--dev-python/smartypants/smartypants-9999.ebuild32
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/smartypants/Manifest b/dev-python/smartypants/Manifest
new file mode 100644
index 000000000000..79e9099de5d4
--- /dev/null
+++ b/dev-python/smartypants/Manifest
@@ -0,0 +1 @@
+DIST smartypants-2.0.1.tar.gz 24152 BLAKE2B 258c9692eec675054dc31f760cf3a9fc3995683d7a15fc549fb390611761c0b09f73e077f5917f9f071a8fc1ae3f06e36f745fdc0e2c368f465e29f6ce51457f SHA512 d47a866a5478c3520251f87a93a468a5eea10318b24b2e8d4bc918d533b5a5789aa56d3a8d5fb8ccff9572fb63e5b6f2eafc44f93fb57a19e6621ebef5d64d9d
diff --git a/dev-python/smartypants/metadata.xml b/dev-python/smartypants/metadata.xml
new file mode 100644
index 000000000000..21caf30ef387
--- /dev/null
+++ b/dev-python/smartypants/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+</maintainer>
+<longdescription lang="en">
+ smartypants is a Python fork of SmartyPants (wha?)
+</longdescription>
+<upstream>
+ <remote-id type="pypi">smartypants</remote-id>
+ <remote-id type="github">leohemsted/smartypants.py</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/smartypants/smartypants-2.0.1.ebuild b/dev-python/smartypants/smartypants-2.0.1.ebuild
new file mode 100644
index 000000000000..0624ab1574f9
--- /dev/null
+++ b/dev-python/smartypants/smartypants-2.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+inherit distutils-r1
+
+DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
+HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+distutils_enable_sphinx docs
diff --git a/dev-python/smartypants/smartypants-9999.ebuild b/dev-python/smartypants/smartypants-9999.ebuild
new file mode 100644
index 000000000000..0624ab1574f9
--- /dev/null
+++ b/dev-python/smartypants/smartypants-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+MY_PN="${PN}.py"
+MY_P="${MY_PN}-${PV}"
+
+inherit distutils-r1
+
+DESCRIPTION="ASCII quote-dot-dash to HTML entity converter"
+HOMEPAGE="https://pypi.python.org/pypi/smartypants/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/leohemsted/smartypants.py.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/leohemsted/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+distutils_enable_sphinx docs