summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild
deleted file mode 100644
index b51f53167f5d..000000000000
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx spelling extension"
-HOMEPAGE="https://github.com/sphinx-contrib/spelling"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pyenchant[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- app-dicts/myspell-en
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source --no-autodoc
-distutils_enable_tests unittest
-
-RDEPEND+="
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
-"
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}