summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild')
-rw-r--r--dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild b/dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild
deleted file mode 100644
index 546c6239f557..000000000000
--- a/dev-python/spyder-vim/spyder-vim-0_pre20220831.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 virtualx
-
-COMMIT="2ccf0d1e6ccaba24bd05b379065ba43bd935c7bf"
-
-DESCRIPTION="Plugin for Spyder to enable Vim keybindings"
-HOMEPAGE="https://github.com/spyder-ide/spyder-vim"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/spyder-5.3.3[${PYTHON_USEDEP}]
- <dev-python/spyder-6[${PYTHON_USEDEP}]
- "
-
-DEPEND="test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
-)"
-
-DOCS=( "README.rst" "doc/example.gif" )
-
-distutils_enable_tests pytest
-
-python_test() {
- virtx epytest
-}