summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sqlitedict')
-rw-r--r--dev-python/sqlitedict/Manifest1
-rw-r--r--dev-python/sqlitedict/metadata.xml12
-rw-r--r--dev-python/sqlitedict/sqlitedict-1.7.0.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sqlitedict/Manifest b/dev-python/sqlitedict/Manifest
new file mode 100644
index 000000000000..2185fa213e44
--- /dev/null
+++ b/dev-python/sqlitedict/Manifest
@@ -0,0 +1 @@
+DIST sqlitedict-1.7.0.tar.gz 28234 BLAKE2B f67187ee27acbe5525b5f0efb8fd85b68e820439e273af8f9ac4e2f223a2c267f252cb0d60366bd51ba9b55cf36d892e02bdfe727a366bfd266005d98d477c9f SHA512 1ef5e0caf81f7ac17eac0d8573c3404ea043c0c5700fe6b4b9f28ac86ad8d97416bad561318898967cf1af0d7e616684ee3044018e24dab3686d43554c74fef1
diff --git a/dev-python/sqlitedict/metadata.xml b/dev-python/sqlitedict/metadata.xml
new file mode 100644
index 000000000000..e0f2a7f3644b
--- /dev/null
+++ b/dev-python/sqlitedict/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">piskvorky/sqlitedict</remote-id>
+ <remote-id type="pypi">sqlitedict</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sqlitedict/sqlitedict-1.7.0.ebuild b/dev-python/sqlitedict/sqlitedict-1.7.0.ebuild
new file mode 100644
index 000000000000..b664c9623ef2
--- /dev/null
+++ b/dev-python/sqlitedict/sqlitedict-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent dict in Python, backed by SQLite and pickle"
+HOMEPAGE="https://github.com/piskvorky/sqlitedict"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+DOCS=(
+ README.rst
+)
+
+python_test() {
+ rm -f tests/db/* || die
+ py.test -v || die
+}