summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ssh2-python')
-rw-r--r--dev-python/ssh2-python/Manifest1
-rw-r--r--dev-python/ssh2-python/ssh2-python-0.27.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ssh2-python/Manifest b/dev-python/ssh2-python/Manifest
index 5a4bbd6fd4d0..e8bc7e2ada53 100644
--- a/dev-python/ssh2-python/Manifest
+++ b/dev-python/ssh2-python/Manifest
@@ -1 +1,2 @@
DIST ssh2-python-0.26.0.tar.gz 1147243 BLAKE2B 56ee98fa8694d6c9e0c163ec0200c96d8330172c0ae4612f40805ac26da02c7cf64fd4dd49841733c36ed7112c62baa036c901a9ef74a33a92a3d8dc66dc27cb SHA512 35f1a5486bc54bf2242d5b1d2fa24bd5365ffa864a8ae0f4a9f8d96f155ba0877e7dafdf87ea9988b146d8a36c203e44ca9a36a83a5060568bf798468e4a8116
+DIST ssh2-python-0.27.0.tar.gz 1146845 BLAKE2B 18512ca23da628ab9f590cd796ee38522116b133ad537b868893276b083b53ca3647b05e47585a26cc667d39b6f796cfae31f1a8cb29d74fe185e8b837453612 SHA512 f215fa11a99c58350d832680ebd1b96cb9e4b4f90621737595c526af083403379b3529361dbfea6ede40c911c267fa2a6d49becfdc55f5604b9a9f903d6d6208
diff --git a/dev-python/ssh2-python/ssh2-python-0.27.0.ebuild b/dev-python/ssh2-python/ssh2-python-0.27.0.ebuild
new file mode 100644
index 000000000000..88f071e99186
--- /dev/null
+++ b/dev-python/ssh2-python/ssh2-python-0.27.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Super fast SSH2 protocol library, Python bindings for libssh2"
+HOMEPAGE="https://pypi.org/project/ssh2-python/"
+SRC_URI="https://github.com/ParallelSSH/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-libs/libssh2
+ dev-libs/openssl
+ sys-libs/zlib
+"
+python_configure_all() {
+ export SYSTEM_LIBSSH2=1
+}