summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stack_data/stack_data-0.1.4.ebuild')
-rw-r--r--dev-python/stack_data/stack_data-0.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/stack_data/stack_data-0.1.4.ebuild b/dev-python/stack_data/stack_data-0.1.4.ebuild
new file mode 100644
index 000000000000..8d3602838639
--- /dev/null
+++ b/dev-python/stack_data/stack_data-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Extract data from Python tracebacks for informative displays"
+HOMEPAGE="https://github.com/alexmojaki/stack_data"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~riscv"
+
+RDEPEND="
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/pure_eval[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest