summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/suds/suds-0.6-r1.ebuild')
-rw-r--r--dev-python/suds/suds-0.6-r1.ebuild19
1 files changed, 1 insertions, 18 deletions
diff --git a/dev-python/suds/suds-0.6-r1.ebuild b/dev-python/suds/suds-0.6-r1.ebuild
index 900f669cccd8..50186d164ef8 100644
--- a/dev-python/suds/suds-0.6-r1.ebuild
+++ b/dev-python/suds/suds-0.6-r1.ebuild
@@ -15,36 +15,19 @@ S="${WORKDIR}/${PN}-jurko-${PV}"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
+IUSE="test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="doc? ( $(python_gen_useflags python2_7) )"
-
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/epydoc[$(python_gen_usedep python2_7)] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
RDEPEND=""
DOCS=( README.rst notes/{argument_parsing.rst,readme.txt,traversing_client_data.rst} )
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_compile_all() {
- # to say that it's both, because it kinda is...
- ! use doc || epydoc -n "Suds - ${DESCRIPTION}" -o doc suds || die
-}
-
python_test() {
esetup.py test
}
-python_install_all() {
- use doc && local HTML_DOCS=( doc/. )
- distutils-r1_python_install_all
-}
-
python_install() {
# test folder makes for file collisions by the eclass
sed -i -e '/^tests/d' suds_jurko.egg-info/top_level.txt suds_jurko.egg-info/SOURCES.txt || die