summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sure/sure-1.4.11.ebuild')
-rw-r--r--dev-python/sure/sure-1.4.11.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/sure/sure-1.4.11.ebuild b/dev-python/sure/sure-1.4.11.ebuild
deleted file mode 100644
index 15447975e25e..000000000000
--- a/dev-python/sure/sure-1.4.11.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="idiomatic assertion toolkit with human-friendly failure messages"
-HOMEPAGE="https://github.com/gabrielfalcao/sure"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )
-"
-
-python_test() {
- nosetests -v tests || die "Tests failed under ${EPYTHON}"
-}