summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/tabulate-0.8.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/tabulate/tabulate-0.8.6.ebuild b/dev-python/tabulate/tabulate-0.8.6.ebuild
index d8c753700d32..845c0f609e16 100644
--- a/dev-python/tabulate/tabulate-0.8.6.ebuild
+++ b/dev-python/tabulate/tabulate-0.8.6.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
@@ -18,9 +19,9 @@ KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
dev-python/wcwidth[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
${RDEPEND}
$(python_gen_impl_dep 'sqlite')