summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testpath/testpath-0.3.ebuild')
-rw-r--r--dev-python/testpath/testpath-0.3.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/testpath/testpath-0.3.ebuild b/dev-python/testpath/testpath-0.3.ebuild
deleted file mode 100644
index efa5591fab24..000000000000
--- a/dev-python/testpath/testpath-0.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Test utilities for code working with files and commands"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- virtual/python-pathlib[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.2-setup.py.patch
- )
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
- }
-
-python_test() {
- distutils_install_for_testing
- cd "${TEST_DIR}"/lib || die
- cp -r "${S}"/tests "${TEST_DIR}"/lib/ || die
- py.test || die
-}