summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/urllib3/urllib3-1.25.8.ebuild')
-rw-r--r--dev-python/urllib3/urllib3-1.25.8.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-python/urllib3/urllib3-1.25.8.ebuild b/dev-python/urllib3/urllib3-1.25.8.ebuild
index e21205e47f94..5ac937b017b5 100644
--- a/dev-python/urllib3/urllib3-1.25.8.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.8.ebuild
@@ -33,14 +33,14 @@ RDEPEND="
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- ${RDEPEND}
- dev-python/brotlipy[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
- ' 'python*')
+ $(python_gen_cond_dep "
+ ${RDEPEND}
+ dev-python/brotlipy[\${PYTHON_USEDEP}]
+ dev-python/mock[\${PYTHON_USEDEP}]
+ dev-python/pytest[\${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
+ " 'python3*')
)
"
@@ -73,7 +73,12 @@ python_test() {
local -x CI=1
# FIXME: get tornado ported
case ${EPYTHON} in
- python*)
+ python2*)
+ ewarn "Tests are being skipped for Python 2 in order to reduce the number"
+ ewarn "of circular dependencies for Python 2 removal. Please test"
+ ewarn "manually in a virtualenv."
+ ;;
+ python3*)
pytest -vv || die "Tests fail with ${EPYTHON}"
;;
esac