summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/virtualenv/virtualenv-20.0.27.ebuild')
-rw-r--r--dev-python/virtualenv/virtualenv-20.0.27.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/virtualenv/virtualenv-20.0.27.ebuild b/dev-python/virtualenv/virtualenv-20.0.27.ebuild
index a8a3d84852f0..651770201985 100644
--- a/dev-python/virtualenv/virtualenv-20.0.27.ebuild
+++ b/dev-python/virtualenv/virtualenv-20.0.27.ebuild
@@ -79,10 +79,13 @@ src_configure() {
}
python_test() {
- # TODO: fix/skip with more granularity tests on pypy3
- if has "${EPYTHON}" pypy3 python2.7; then
- einfo "Skipping broken tests on pypy3"
- continue
+ if ! python_is_python3; then
+ ewarn "Tests are skipped on py2, please test externally"
+ return
+ elif [[ ${EPYTHON} == pypy3 ]]; then
+ # TODO: skip with better granularity
+ ewarn "Skipping broken tests on pypy3"
+ return
fi
distutils_install_for_testing