summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/visitor/visitor-0.1.3-r2.ebuild')
-rw-r--r--dev-python/visitor/visitor-0.1.3-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/visitor/visitor-0.1.3-r2.ebuild b/dev-python/visitor/visitor-0.1.3-r2.ebuild
new file mode 100644
index 000000000000..d1baf6a25481
--- /dev/null
+++ b/dev-python/visitor/visitor-0.1.3-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tiny pythonic visitor implementation"
+HOMEPAGE="https://github.com/mbr/visitor"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/visitor/pull/2
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest