summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/visitor/visitor-0.1.3.ebuild')
-rw-r--r--dev-python/visitor/visitor-0.1.3.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/visitor/visitor-0.1.3.ebuild b/dev-python/visitor/visitor-0.1.3.ebuild
index b6ff311f6c16..56399f3c1fc5 100644
--- a/dev-python/visitor/visitor-0.1.3.ebuild
+++ b/dev-python/visitor/visitor-0.1.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -19,11 +19,8 @@ IUSE="test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-RDEPEND=""
python_test() {
py.test || die "Tests failed with ${EPYTHON}"