summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vpython/vpython-7.6.2.ebuild')
-rw-r--r--dev-python/vpython/vpython-7.6.2.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/vpython/vpython-7.6.2.ebuild b/dev-python/vpython/vpython-7.6.2.ebuild
deleted file mode 100644
index cbf767586bd9..000000000000
--- a/dev-python/vpython/vpython-7.6.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="VPython for Jupyter notebook"
-HOMEPAGE="https://www.vpython.org/ https://pypi.org/project/vpython/"
-SRC_URI="https://github.com/${PN}/${PN}-jupyter/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-jupyter-${PV}"
-
-RDEPEND="
- >=dev-python/autobahn-18.8.2[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter[${PYTHON_USEDEP}]
- dev-python/jupyter-server-proxy[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/versioneer[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- ${BDEPEND}
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="test"
-PATCHES="${FILESDIR}/${P}-fix-python310-detection.patch"
-
-distutils_enable_tests pytest