summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wcwidth/wcwidth-0.2.5.ebuild')
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.2.5.ebuild b/dev-python/wcwidth/wcwidth-0.2.5.ebuild
deleted file mode 100644
index f4b955e9c11d..000000000000
--- a/dev-python/wcwidth/wcwidth-0.2.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
-HOMEPAGE="https://pypi.org/project/wcwidth/ https://github.com/jquast/wcwidth"
-SRC_URI="
- https://github.com/jquast/wcwidth/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
- ' -2)"
-
-distutils_enable_tests pytest
-
-DOCS=()
-
-src_prepare() {
- sed -e 's:--cov-append::' \
- -e 's:--cov-report=html::' \
- -e 's:--cov=wcwidth::' \
- -i tox.ini || die
- sed -i -e 's:test_package_version:_&:' tests/test_core.py || die
- distutils-r1_src_prepare
-}