summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/werkzeug/werkzeug-1.0.1.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-1.0.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/werkzeug/werkzeug-1.0.1.ebuild b/dev-python/werkzeug/werkzeug-1.0.1.ebuild
deleted file mode 100644
index e8ca9a64eead..000000000000
--- a/dev-python/werkzeug/werkzeug-1.0.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="Werkzeug"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Collection of various utilities for WSGI applications"
-HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
-#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-SRC_URI="https://github.com/pallets/werkzeug/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # this test is very unreliable; it may fail randomly depending
- # on installed packages
- sed -i -e 's:test_no_memory_leak_from_Rule_builder:_&:' \
- tests/test_routing.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- pytest -vv -x -p no:httpbin tests/test_routing.py || die "Tests fail with ${EPYTHON}"
-}