summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/whatever/whatever-0.6.ebuild')
-rw-r--r--dev-python/whatever/whatever-0.6.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/whatever/whatever-0.6.ebuild b/dev-python/whatever/whatever-0.6.ebuild
index f6c9bab53d16..d658858e1c31 100644
--- a/dev-python/whatever/whatever-0.6.ebuild
+++ b/dev-python/whatever/whatever-0.6.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="A collection of fancy functional tools focused on practicality"
HOMEPAGE="https://github.com/Suor/whatever"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/Suor/whatever/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
+
+distutils_enable_tests pytest