summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.36.1.ebuild38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index 056638b6ea71..fa55c58f41f2 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,2 +1 @@
-DIST wheel-0.36.1.gh.tar.gz 65846 BLAKE2B 906bd8887ab0efc6542547c603d613e6b12e4ea56e8d037c3a4532e064f3d337cd5c161e2c2557cc832262a42eeda2850303f1d92e8de45f44321ebc9d47c955 SHA512 1f9a27604b0fa0d1ae4782bdba57956a70d74a9a736f4c41481b417cd1e8a86938705555c37835ffe1a061ef55f8adad3475bfc20e2c1fd8de8083dd5c72cca0
DIST wheel-0.36.2.gh.tar.gz 67999 BLAKE2B 0bb6742ddb25a5b94f94fd071dfe63ae5fa555731625b4b8ca2c7abb1a255e24590ae9ea250ada0473fcd74f19bdca7e529f8eda1a79d8e394d8b339bd2a257a SHA512 23f3dd0540ecc8e762f37a4bb69713abe99125a605c03b1a3412cec910fb7a6cea3eee3910d7c98122b276170a17414c9132b57b57a30a4ba1283cea8f9e20fa
diff --git a/dev-python/wheel/wheel-0.36.1.ebuild b/dev-python/wheel/wheel-0.36.1.ebuild
deleted file mode 100644
index 06960f8a8059..000000000000
--- a/dev-python/wheel/wheel-0.36.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="https://pypi.org/project/wheel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-macos"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed \
- -e 's:--cov=wheel::g' \
- -i setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- if ! python_is_python3; then
- # install fails due to unicode in paths
- ewarn "Testing is broken with py2.7, please test externally"
- return
- fi
-
- distutils_install_for_testing --via-root
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}