summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/wheel-0.34.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/wheel/wheel-0.34.2.ebuild b/dev-python/wheel/wheel-0.34.2.ebuild
index 0006226aeb7e..80c4b19e4e16 100644
--- a/dev-python/wheel/wheel-0.34.2.ebuild
+++ b/dev-python/wheel/wheel-0.34.2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
inherit distutils-r1 eutils
@@ -25,3 +25,8 @@ src_prepare() {
-i setup.cfg || die
distutils-r1_src_prepare
}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}