summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/whoosh/whoosh-2.7.4.ebuild')
-rw-r--r--dev-python/whoosh/whoosh-2.7.4.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/whoosh/whoosh-2.7.4.ebuild b/dev-python/whoosh/whoosh-2.7.4.ebuild
deleted file mode 100644
index 3ca02d1cda5a..000000000000
--- a/dev-python/whoosh/whoosh-2.7.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
-HOMEPAGE="https://bitbucket.org/mchaput/whoosh/wiki/Home/ https://pypi.org/project/Whoosh/"
-SRC_URI="mirror://pypi/W/${PN^}/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-solaris"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.7.4-tests-specify-utf8.patch
-)
-
-distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # (backport from upstream)
- sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
- # fix old section name
- sed -i -e 's@\[pytest\]@[tool:pytest]@' setup.cfg || die
- # TODO: broken?
- sed -i -e 's:test_minimize_dfa:_&:' tests/test_automata.py || die
-
- distutils-r1_python_prepare_all
-}