summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wtforms/wtforms-1.0.4.ebuild')
-rw-r--r--dev-python/wtforms/wtforms-1.0.4.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/wtforms/wtforms-1.0.4.ebuild b/dev-python/wtforms/wtforms-1.0.4.ebuild
deleted file mode 100644
index 6622012f896e..000000000000
--- a/dev-python/wtforms/wtforms-1.0.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="http://wtforms.simplecodes.com/ https://pypi.python.org/pypi/WTForms"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_P}"
-
-DEPEND="app-arch/unzip
- doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )"
-RDEPEND=""
-
-DOCS="AUTHORS.txt CHANGES.txt README.txt"
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- PYTHONPATH=".." emake html || die "Building of documentation failed"
- fi
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
- fi
-}