summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xcffib/xcffib-0.9.0.ebuild')
-rw-r--r--dev-python/xcffib/xcffib-0.9.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/xcffib/xcffib-0.9.0.ebuild b/dev-python/xcffib/xcffib-0.9.0.ebuild
new file mode 100644
index 000000000000..e568cadb7fac
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
+
+python_test() {
+ virtx nosetests -d -v
+}