summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zope-event/zope-event-4.4.ebuild')
-rw-r--r--dev-python/zope-event/zope-event-4.4.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/zope-event/zope-event-4.4.ebuild b/dev-python/zope-event/zope-event-4.4.ebuild
deleted file mode 100644
index fa29e97fc941..000000000000
--- a/dev-python/zope-event/zope-event-4.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Event publishing / dispatch, used by Zope Component Architecture"
-HOMEPAGE="https://github.com/zopefoundation/zope.event http://docs.zope.org/zope.event/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-distutils_enable_tests nose
-
-S="${WORKDIR}/${MY_P}"
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # remove .pth files since dev-python/namespace-zope handles the ns
- find "${D}" -name '*.pth' -delete || die
-}