summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libvirt-python/libvirt-python-9999.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/dev-python/libvirt-python/libvirt-python-9999.ebuild b/dev-python/libvirt-python/libvirt-python-9999.ebuild
index a8d6ae5dc1b6..1e00660e0ab1 100644
--- a/dev-python/libvirt-python/libvirt-python-9999.ebuild
+++ b/dev-python/libvirt-python/libvirt-python-9999.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
MY_P="${P/_rc/-rc}"
inherit distutils-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-python.git"
- SRC_URI=""
- KEYWORDS=""
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
RDEPEND="app-emulation/libvirt:=[-python(-)]"
else
SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
@@ -29,14 +29,13 @@ SLOT="0"
IUSE="examples test"
RESTRICT="!test? ( test )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
+DEPEND="virtual/pkgconfig"
+BDEPEND="test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+)"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py
python_install_all() {
if use examples; then