summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-0.41.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index e91fd0c9d8c2..8980ddc311cc 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,3 +1,4 @@
DIST WeasyPrint-0.29.tar.gz 1418105 SHA256 4edf5538b330be3e559f006db76a5a948c25f3792746aafb20f2a9d6185f0e71 SHA512 3875240b7bed6991372f6a45f82d32f0d2f3add29ab1937001c5559368405737d185aa85871358730989a91ee6b17e62cc21535735c884c47705d0d2d38bb167 WHIRLPOOL cbefe32d42e5bbc26993b58f88b2ebc26291579dd717805c8fc9c54d41fe69b3a05eb8f301e9c21b426766404c9a683cce6c115ed8193456d17c83b44c8513a9
DIST WeasyPrint-0.39.tar.gz 386613 SHA256 ed0be652bd396a9b818f015c8bc5fb32040864ee86cda6f0160cdef1dd4f42d0 SHA512 668eed8c4f2502b3412166ea8e7b15b838b971b175ac3ec2370097b83557070684fa7bc9c62c3222056294093781649f263aba756091fb87d50ceea339e32e43 WHIRLPOOL d7b987dbef301346a83418f7a8796f0d7c3076c5b8aadc66da1779e86198864e8c6c91ea3edc7d3ebbe8820a0e5a73b11c07a7cf1b7b7a9a9c3aeebb900d7490
DIST WeasyPrint-0.40.tar.gz 388586 SHA256 b7e00cd5c4c3de4e659cca0e02670c37bf2fcf7a57251cbfe23e31cbf9782a6b SHA512 9c0d082ed2c35f76fe8ca5d25b5e99a0f96a309b2c4715ca3bd72a3a9a11121d4f5046c4ff55f007ebf0404edb0e4f510e571f42c569778948320be0301b8c4d WHIRLPOOL 209c3aed8a03212c34a523fb777c6626b860a3eabd9b3f8d2b6ea61f40f8e606ee59e92020116b61e76b514b9d17056237ef7c1e298fdc3e98e80781aca5dc43
+DIST WeasyPrint-0.41.tar.gz 393866 SHA256 1905d906a5560472045e001779c37ccbad8f2c4fe7b9eee7999b4f2096157b23 SHA512 44b2d9e0a186c5767cd01d6e66495241d088908467e0fa28cee114a9c480bfcb4ef393236e9304653603f3917c73c452c05a38286932e0a271946860120d9a1f WHIRLPOOL ddc5edfb8b171a52d9ad5f9a49906fb476c601291176366ae3b9f820c6ed15b1907e18993076a4dc235a956d7ee9c955c6406ec89691975573a361b09e6a0b68
diff --git a/dev-python/weasyprint/weasyprint-0.41.ebuild b/dev-python/weasyprint/weasyprint-0.41.ebuild
new file mode 100644
index 000000000000..ef4488009e94
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-0.41.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+MY_PN="WeasyPrint"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://weasyprint.org https://github.com/Kozea/WeasyPrint"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="jpeg jpeg2k test tiff"
+
+# Note: specific subslot of pango since it inlines some of pango headers.
+RDEPEND="
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf[jpeg?,jpeg2k?,tiff?]
+ x11-libs/pango:0/0
+ >=dev-python/cairocffi-0.5[${PYTHON_USEDEP}]
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.8[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-1.0.20[${PYTHON_USEDEP}]
+ >=dev-python/pdfrw-0.4[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-flake8[${PYTHON_USEDEP}]
+ dev-python/pytest-isort[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-fonts/ahem
+ )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}