summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dbus-python/Manifest1
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.4.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index 67bd685a80d5..72092cc1d976 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1 +1,2 @@
DIST dbus-python-1.2.0.tar.gz 602426 SHA256 e12c6c8b2bf3a9302f75166952cbe41d6b38c3441bbc6767dbd498942316c6df SHA512 013b23e08fa1ed43f53a756587fefbc9770f7c51e93510e555acbd77230b7200693419bba9a69680d790bbaf123f4a195afa38b3eee1143da950fee0b5130bce WHIRLPOOL 2b505646c21afd6238f32cda7aaf5f4b770d3c82b0d5c2c254f044729d6e06d3eab89cf816dbd22e96b8d8e1550297521dcb49fc90bb4825fdafd12d5beba5ee
+DIST dbus-python-1.2.4.tar.gz 612112 SHA256 e2f1d6871f74fba23652e51d10873e54f71adab0525833c19bad9e99b1b2f9cc SHA512 efdd9d96a8b56e813c93208d34777f1ca2db96c076d31f13afbcaec3c7770a16a623d5531fe23443130c555240949802503f171f2064d45eee97546d6251304b WHIRLPOOL aa855733df07bf22b5ca9fe24506b6417c202777110dddba4227c6833148fb169f3afeb9c219b366d0f207f7ce65ac17ac23c143bc38242cac3dffaecedb251a
diff --git a/dev-python/dbus-python/dbus-python-1.2.4.ebuild b/dev-python/dbus-python/dbus-python-1.2.4.ebuild
new file mode 100644
index 000000000000..8e6e38ba8d00
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-1.2.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit autotools eutils python-r1
+
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/DBusBindings http://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="http://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint"
+IUSE="doc examples test"
+# API docs generated with epydoc, which is python2-only
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ doc? ( python_targets_python2_7 )"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.100:=
+ >=sys-apps/dbus-1.6:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ dev-python/docutils[python_targets_python2_7?]
+ =dev-python/epydoc-3*[python_targets_python2_7?] )
+ test? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ default
+ # Update py-compile, bug 529502.
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ configuring() {
+ local PYTHON_CONFIG
+ python_export PYTHON_CONFIG
+
+ # epydoc is python2-only, bug #447642
+ local apidocs=--disable-api-docs
+ [[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-html-docs \
+ ${apidocs} \
+ PYTHON_INCLUDES="$(${PYTHON_CONFIG} --includes)" \
+ PYTHON_LIBS="$(${PYTHON_CONFIG} --ldflags)"
+ # configure assumes that ${PYTHON}-config executable exists :/
+ }
+ python_foreach_impl run_in_build_dir configuring
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installing() {
+ default
+ [[ ${EPYTHON/.*} = "python2" ]] && use doc && dohtml -r api/*
+ }
+ python_foreach_impl run_in_build_dir installing
+ prune_libtool_files --modules
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}