summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.17.31.ebuild62
-rw-r--r--dev-python/botocore/botocore-9999.ebuild2
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 73fecbca6f64..71b9e1769bf4 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.17.20.tar.gz 6557688 BLAKE2B a4d17d436a7af1a9825ebc0bcb23d0cb32b
DIST botocore-1.17.23.tar.gz 6564852 BLAKE2B cc1da91f4a45964fe684b015de9db253059241f654dac93901cde5dc24f3ab3595ecd201be91bed36236bb885c7ec7aed998025f6c0ea8b050c13d17a6431238 SHA512 93af672e8d110ab4989e9abc20b3bbb1a6c9050c379bb1db8542e9027e6a4ee82083645c59211204d7110e112d393f80f87d15b77337a4d73358f43d39f6e52f
DIST botocore-1.17.27.tar.gz 6637309 BLAKE2B 8c3d8d27b13c55c11b4934e0af35bb0a01c67e0c30d33ce54710d3e3c967101c5d9258fc2317f86c9f8271044e977015b185015aafd3af748fe581f3120ea32d SHA512 9dc3341b6de7801da13f71730bcb2bf9c4295618303a1c98973cabb2aef947b5756352f3a9939b8fbe04a92c3a7cde6ed88f55c982f7dc412f7dff898bc75bc2
DIST botocore-1.17.28.tar.gz 6647521 BLAKE2B e9da32dd9202bc1ad621003bb6196873380f0015553cd906465382d21d30b7b83313e6be4e8d3d8abf4f6472180319a98677a3a245ad69bf6bde5d8e08264577 SHA512 5388518dc0bf598a3ea848df38454c49692abaf7ebe23e0ab0b1416139a4363b712260591e644c415ea3ea4cbac105011fef4d565b95fd3045fe6e4d3c7318a8
+DIST botocore-1.17.31.tar.gz 6665851 BLAKE2B dbc89d1216f9fda89c6185baccfdf2878c265d8761e4ad1349a45d334f9a4d5b79ad1ce06a19a7a706b75be1a6d7f2a7bf5bc33d8ffbe7ad8a016472edf0432f SHA512 ab1921fae887846d1c224d624e8d5dd888ab9c0c90a415ac97e5ad2f7563131b199e8870553e7f3dd6f5ff4c7901aa04bfa99160aca4e9da8ef3096cfd922ec9
diff --git a/dev-python/botocore/botocore-1.17.31.ebuild b/dev-python/botocore/botocore-1.17.31.ebuild
new file mode 100644
index 000000000000..6b14dce9712f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.17.31.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # py3.9
+ find -name '*.py' -exec \
+ sed -i -e 's:cElementTree:ElementTree:' {} + || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 3a39d76a0538..6b14dce9712f 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -6,7 +6,7 @@ PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
-DESCRIPTION="Low-level, data-driven core of boto 3."
+DESCRIPTION="Low-level, data-driven core of boto 3"
HOMEPAGE="https://github.com/boto/botocore"
LICENSE="Apache-2.0"
SLOT="0"