summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests_pkcs12/Manifest1
-rw-r--r--dev-python/requests_pkcs12/metadata.xml4
-rw-r--r--dev-python/requests_pkcs12/requests_pkcs12-1.10.ebuild24
3 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/requests_pkcs12/Manifest b/dev-python/requests_pkcs12/Manifest
index be8b8ff46aa9..b73c1ddc6e29 100644
--- a/dev-python/requests_pkcs12/Manifest
+++ b/dev-python/requests_pkcs12/Manifest
@@ -1 +1,2 @@
+DIST requests_pkcs12-1.10.tar.gz 4284 BLAKE2B 46ebbb00921f356ccf5793fe486d3e0d71b9b1688cb49d1c846c2ef808087bb51b71c18e89539946bf4b0c8d47df5ae7acda342b0e1293bf8a031eba5ba0ace5 SHA512 139d1b1ae740db7667bb079f955610ebbe6327dd6f050d59a0e6603f21a9fe0afde8dcb2ec666bc83f6b4205de05948dacf39bdec2d9f26bf3eaa7d6998f2fbb
DIST requests_pkcs12-1.7.tar.gz 3914 BLAKE2B f91c7d1677964cfe903b4c0f688e25b5b3b7eb921fdeb4e794cbea24ceafe4e44f7587df48c0ad56ff20114641f6897ab4ef26a64b53e6fcb7d713ecf36bb1c0 SHA512 be3fe00ef405b44d9f160ff35c072b86da511a68380e2737e9316a0d1dd89c3d8ba7adbaaf9865ca01cfbbdb85c477364780cbe3e77e2963dcd7b54519a95356
diff --git a/dev-python/requests_pkcs12/metadata.xml b/dev-python/requests_pkcs12/metadata.xml
index 0a878536db01..e0df1fd7383b 100644
--- a/dev-python/requests_pkcs12/metadata.xml
+++ b/dev-python/requests_pkcs12/metadata.xml
@@ -5,6 +5,10 @@
<email>gyakovlev@gentoo.org</email>
<name>Georgy Yakovlev</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<longdescription lang="en">
Adds PKCS#12 support to the Python requests library in a clean way, without monkey patching or temporary files.
</longdescription>
diff --git a/dev-python/requests_pkcs12/requests_pkcs12-1.10.ebuild b/dev-python/requests_pkcs12/requests_pkcs12-1.10.ebuild
new file mode 100644
index 000000000000..d5fd9b39c41e
--- /dev/null
+++ b/dev-python/requests_pkcs12/requests_pkcs12-1.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Adds PKCS#12 support to the Python requests library in a clean way"
+HOMEPAGE="https://github.com/m-click/requests_pkcs12"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=""
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test" # no tests