summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-4.0.3.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index b678d7214c4c..4cc75ec38674 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,2 +1 @@
-DIST icalendar-4.0.3.tar.gz 77899 BLAKE2B d4043914b85359a8309dd7c8acce55ec5921508319342f2ffb2e16017aa5aa164ef7fdd44aee7820a971516a3e157b5c8ee86732e669c8eac4b5c4bc1767e334 SHA512 2f0ac5a7f36c7d37047ba20bec3f2ca7df51a9e3ec3f29751c71cdd264c01f7e0abd6efc298dac5a7c87911cb4916e56bf77716d6ca05a2d090e26486e6a56be
DIST icalendar-4.0.6.tar.gz 78418 BLAKE2B 4941262cca63cae4df249b6ec01b73b640caa002d011ed19aead89fdfc6fe9a7e37258d95668142137faf635403986a2ea4d3e39dd565d1205dfb238fd13e98f SHA512 e8f7ee878cc14b75636268d7b8c79569ce1875142fb907b1eb74bc6b9cf96f218e4be63828190aa2a27978c431437c1d454febe9a2da58c5f2785e283ae725b2
diff --git a/dev-python/icalendar/icalendar-4.0.3.ebuild b/dev-python/icalendar/icalendar-4.0.3.ebuild
deleted file mode 100644
index 99fff99f2dc0..000000000000
--- a/dev-python/icalendar/icalendar-4.0.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
-HOMEPAGE="https://github.com/collective/icalendar"
-SRC_URI="mirror://pypi/i/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DOCS=( "README.rst" )
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # reset conf.py to not read version from an installed instance
- sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
- -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- pytest -vv src/icalendar || die "test failed under ${EPYTHON}"
-}