summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-12.4.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index c88ee8df939f..3fe59e4945a5 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,4 @@
DIST rich-12.2.0.gh.tar.gz 14884722 BLAKE2B fb3720724d2441cddd85ac22249aa232bd31f664019f9eb02e10fda913b98c0220a4fadff47fc0f6884ff77b7ee9f98a96e036fb76d0492e0c040d752a9e9c79 SHA512 8f8108557ca21e41b35c03242d203c229f7af0d7abf5b394fc894e71ae098bbc14e046b166e5452d7a9f9d7d6e8cc0e13784d64cd721d2f7acec9f624d14db77
DIST rich-12.3.0.gh.tar.gz 14889665 BLAKE2B baa098e25768b4b84a269547c7726d281f67e333c0993513223dfdda7023001ea78b6edd10218726ae888e7216e18c6c4d5b9711268d083dfd0a41c3162658c9 SHA512 6df0ac70ffac7aca5726c9ea29c6eeada1ff955539842a1352eaa7f7e95c4c7ec57f4e2eaca6808e522d7e455efa80df2ccc3e20188f4646ad0e18294b59f744
DIST rich-12.4.0.gh.tar.gz 14890620 BLAKE2B fe38abeec7f896053fc2f13259694dd90378db5318683243cf7b13add91c356992b9e4faa475aa282af70694b14e7c82e54c292bd3bcb4411d460dc831310b26 SHA512 dec7903854b29d13b31d3b17a592cd6b94ea1fb6626f7d8abae57927e8cd8021a51cf060b0f431d6fd8a358ae6938038f5aad0c695afa121e05ab3e97aa61006
+DIST rich-12.4.1.gh.tar.gz 14890981 BLAKE2B 7eb8424ca5e3a985e6d000ed2c74784dba104237a67315c59d3f3cdf71a7196621566b9f40f7ca0e9f74d6bcd1daae781ee2aef871f5fbf738d3209ae13dba4a SHA512 ee02526c5e717976c2b4a8e750dc9f87d5b2d15a9b144aabb8e84de01ba4df78985ad5ed6bbcf9f6e42a76a63cab6da76c05da917aa8c09d678858fa148db76c
diff --git a/dev-python/rich/rich-12.4.1.ebuild b/dev-python/rich/rich-12.4.1.ebuild
new file mode 100644
index 000000000000..e83ce3f6aa64
--- /dev/null
+++ b/dev-python/rich/rich-12.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/Textualize/rich"
+SRC_URI="
+ https://github.com/Textualize/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ local EPYTEST_DESELECT=(
+ # broken with =dev-python/pygments-2.12.0
+ tests/test_console.py::test_size_can_fall_back_to_std_descriptors
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}