summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xdoctest/Manifest2
-rw-r--r--dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch28
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.8.ebuild33
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.9.ebuild29
4 files changed, 0 insertions, 92 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index b32294e6f834..27abaf468fdc 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1,3 +1 @@
DIST xdoctest-0.15.10.gh.tar.gz 191579 BLAKE2B 4836b773c3cf664c825433199b13ab7d3fe2c68538517bf5594797ad3f2f894d0132034fdafbc4502a00ec7393c19473fafe15fcf0257e3565592dc9907e3d71 SHA512 18c1a2774ae9331582610e3459a02f4e4de838218e7250af071570b2318f4c14330084b9fb903d88651fc40a4ba12b686ee6f2ca165edd8155e908ae4992a840
-DIST xdoctest-0.15.8.gh.tar.gz 185463 BLAKE2B a16578e6d50398ac80d950bcc9a05131880816e2ff3a15bd1489474e532f9b495d099dcea204d8375c884c6957aaaba9b276fbcb65b5717b2850314453f787f7 SHA512 ab4f991ba6e312bf6cf675c3bbeeae87c0666b96c911ee7727f64b8e4c13420bb91e0a7a955ebce73b3fb15625b52bbf1b67c6edfe91234655501060b17723d5
-DIST xdoctest-0.15.9.gh.tar.gz 190313 BLAKE2B 9980752ad5742a7c4a73418a3ace408c38a6bef6cd43ee5cd1893d6cb195a7c387c5062735b2c903725898ea670e3e6d8e683d4341dcf2dc9e17a2c723107910 SHA512 6a49fbe7f2535ab86ac7047406fbcc9f7e98c964664a95a115c3d945ba8157e4e70ab8c31edae6faee932cfd5e90201d883d9b4b10e2cea9cdc8ff14b5d52d54
diff --git a/dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch b/dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch
deleted file mode 100644
index 193b3f51bbac..000000000000
--- a/dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ec14218904fdd1c06597277deb11c8d3bb33c675 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Fri, 3 Sep 2021 07:27:22 +0200
-Subject: [PATCH] Fix test failure if pytest's flaky plugin is installed
-
-Disable pytest's flaky plugin in test_simple_pytest_import_error_cli
-in order to fix a test failure due to it mangling pytest's return code
-on import error.
----
- testing/test_pytest_cli.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/testing/test_pytest_cli.py b/testing/test_pytest_cli.py
-index 25c8363..8ef9251 100644
---- a/testing/test_pytest_cli.py
-+++ b/testing/test_pytest_cli.py
-@@ -67,7 +67,7 @@ def test_simple_pytest_import_error_cli():
- """
- ''')
- temp_module = util_misc.TempModule(module_text, modname='imperr_test_mod')
-- command = sys.executable + ' -m pytest -v -s --xdoctest-verbose=3 --xdoctest ' + temp_module.dpath
-+ command = sys.executable + ' -m pytest -p no:flaky -v -s --xdoctest-verbose=3 --xdoctest ' + temp_module.dpath
- print(command)
- info = cmd(command)
- print(info['out'])
---
-2.33.0
-
diff --git a/dev-python/xdoctest/xdoctest-0.15.8.ebuild b/dev-python/xdoctest/xdoctest-0.15.8.ebuild
deleted file mode 100644
index 2fca586c7c28..000000000000
--- a/dev-python/xdoctest/xdoctest-0.15.8.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
-HOMEPAGE="https://github.com/Erotemic/xdoctest/"
-SRC_URI="
- https://github.com/Erotemic/xdoctest/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-# dev-python/nbformat-5.1.{0..2} did not install package data
-BDEPEND="
- test? (
- >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-#distutils_enable_sphinx docs/source \
-# dev-python/autoapi \
-# dev-python/sphinx_rtd_theme
-
-PATCHES=(
- "${FILESDIR}"/${P}-pytest-flaky.patch
-)
diff --git a/dev-python/xdoctest/xdoctest-0.15.9.ebuild b/dev-python/xdoctest/xdoctest-0.15.9.ebuild
deleted file mode 100644
index 3f8b3416a702..000000000000
--- a/dev-python/xdoctest/xdoctest-0.15.9.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
-HOMEPAGE="https://github.com/Erotemic/xdoctest/"
-SRC_URI="
- https://github.com/Erotemic/xdoctest/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-# dev-python/nbformat-5.1.{0..2} did not install package data
-BDEPEND="
- test? (
- >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-#distutils_enable_sphinx docs/source \
-# dev-python/autoapi \
-# dev-python/sphinx_rtd_theme