summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-0.10.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 3cbf26b8a128..05fafc1873a0 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1,2 +1,3 @@
DIST rope-0.10.3.tar.gz 226123 SHA256 eb45bea0abcf31a1a12ff087b990060e64244b835582ebc7642e6f7ea1fd65a2 SHA512 1d868aeebd086c3fc199316a71e61a8c46c76d85176557842051bb8f51d090f316df6bb84f766db5a46dc164d3e471eb90465805a102e46acb34e39b2b0ce8b4 WHIRLPOOL 16cd8b80f7f3fe729d1d3b4b5b98fcd5b6f16c818ddd67a9d460fe4947e768febf1425e8d20bf0e47c9d49a58b4ba1acac0e6640d61fc187f84fc843128c591d
DIST rope-0.10.5.tar.gz 243931 SHA256 2ff6099e65798f9e27da5026cc7136b4d9b340fc817031ccb4318f61f448127f SHA512 90a055be51834cc642f06b2bbcad4419d15605393a784a414c069a43816243badcbe5fa131bac48a5899268fcbdc11292c8469d30747614b7c85eebb8f2b6fae WHIRLPOOL bafe308c6f22805256dfe6b8b7e6d11c89afeca51837fac877fd94baa8610386f9e09fd03901271705c8b2fc72754a19e394d6e8999ec6d9f6b23d4cd8791fdd
+DIST rope-0.10.7.tar.gz 244089 SHA256 a09edfd2034fd50099a67822f9bd851fbd0f4e98d3b87519f6267b60e50d80d1 SHA512 80343b8b7af883afbd04734b0fe4dbdab114301234654cbd95b3ae8be8dff40878105b7647209f5e899b981ab6a7ecb987d9bdf942b32ed083c745128c22ef95 WHIRLPOOL e002d4defc2076c9c550a8b4a27df54488a209ce8aaad769a46e25c90b73cf7263bb214f9cc0db7a577f3d81958e20f9028023d5cfd9e4a6590f3ecb40d06408
diff --git a/dev-python/rope/rope-0.10.7.ebuild b/dev-python/rope/rope-0.10.7.ebuild
new file mode 100644
index 000000000000..88eae38207d2
--- /dev/null
+++ b/dev-python/rope/rope-0.10.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.10.3-doc-syntax-errors.patch" )
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+python_compile_all() {
+ if use doc; then
+ pushd docs > /dev/null || die
+ mkdir build || die
+ local i
+ for i in ./*.rst; do
+ rst2html.py $i > ./build/${i/rst/html} || die
+ done
+ popd > /dev/null || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/. )
+ distutils-r1_python_install_all
+}