summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.0.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index f9c12ac0e1bd..7b92dbd0ccc4 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,2 @@
-DIST sphinxcontrib-spelling-5.1.0.tar.gz 22942 BLAKE2B 00861b429b66667ed45791f9dd8394b23cf2982875a9e3470c1e2dee22ff0500515d409821a73e46b49bcf397e9ef40f377f933e460b8673579b1f234bf157e4 SHA512 22c5c4eac56c0138e33aae38c2ed1d254211c502087e4c0ebebf2b3b7df69d2567cacde394abb2d8385eab48ea6e3ac9282c980bc8b52408f46bc06ab9634fa4
DIST sphinxcontrib-spelling-5.1.2.tar.gz 22962 BLAKE2B c7b15289b4b6dce5e6c5fb529c4be2cd7c1f41d8bfc6ac86daf1a982f711bd2c426d9b3a615471538fe221197b64ccd907efd4620ea2440f6ec07b2a078d6bee SHA512 4a0398b7c79a035e12d9ae96100fcaa4df42aeae07a01a73f7d875ba04fbbeb3d7441c9debe77491876d78b0a3753677cff4cb3a575e3490364fe5780f5a70b2
DIST sphinxcontrib-spelling-5.2.0.tar.gz 43860 BLAKE2B 535ec4d8d6f924c9f01b10599725295b1f96f47e999393fbc603725b0eb4ffccf7f12be636cc2d9d045251cae075a3e851f3de4cee5d64ca24ca2056a5406274 SHA512 a17932c5b656cfb76a1389d7c56d71b41d0dda37fae0449db2e03ae1694a6741d20ce2b057ff8bc5fc4fc26c91e07f5a1106470deeea2633ca7a60bc7537c2aa
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.0.ebuild
deleted file mode 100644
index 4eef4eb94bf6..000000000000
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx spelling extension"
-HOMEPAGE="https://github.com/sphinx-contrib/spelling"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pyenchant[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${COMMON_DEPEND}
- app-dicts/myspell-en
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${COMMON_DEPEND}
- dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}